Feedback

type to search
lakef

Lakef

joined | seen

Badges

Lakef created

PROBLEM SOLVED I booted the computer with the Debian install USB-memory-stick. In the Debuab GNU/Linux UEFI installer menu, I selected advanced options > graphical expert install. When I had the message that GRUB could not be installed, I ran a shell (from within the graphical expert install). This is what I wrote in the shell: cd /target mount --rbind /proc proc/ mount --rbind /sys sys/ mount --rbind /dev dev/ mount --rbind /run run/ chroot . /bin/bash I got a root@XXX$ prompt where I wrote: apt-get update apt-get install grub-efi-amd64 update-grub grub-install I quit the shell and finished the installation. I withdrew the USB-memory-stick and rebooted. Then I could log into Debian!!! It seems like the problem is solved!

Lakef updated

PROBLEM SOLVED I booted the computer with the Debian install USB-memory-stick. In the Debuab GNU/Linux UEFI installer menu, I selected advanced options > graphical expert install. When I had the message that GRUB could not be installed, I ran a shell (from within the graphical expert install). This is what I wrote in the shell: cd /target mount --rbind /proc proc/ mount --rbind /sys sys/ mount --rbind /dev dev/ mount --rbind /run run/ chroot . /bin/bash I got a root@XXX$ prompt where I wrote: apt-get update apt-get install grub-efi-amd64 update-grub grub-install I quit the shell and finished the installation with the graphical expert install. Please note that, because I had already installed GRUB via the command line, I declined to install GRUB when asked by the graphical interface. I withdrew the USB-memory-stick and rebooted. Then I could log into Debian!!! Note: grub-efi-amd64 above should be replaced by grub-efi-amd32 for a 32-bit architeture. If one writes grug-efi-amd, then the correct architecture is chosen automatically. It seems like the problem is solved!

You need to join Debian to complete this action, click here to do so.