Feedback

type to search

issueing reboot does not really reboot the computer

Asked by [ Editor ] , Edited by Helmut Grohne [ Editor ]

Hi Everyone,
I just did a clean install of Debian xfce4 from the Squeeze live CD.
I found out that issuing reboot, does not really reboot. Instead of going all the way to grub menu, it shuts all services, and reload the kernel and all services.

I have never seen such behaviour, and I’m guessing it is somehow related to the new grub2.
Can some enlighten me ?

Thanks,
Oz

NN comments
asjo
-

What do you mean “reload the kernel”? You don’t get the usual BIOS stuff?

or Cancel

5 answers

3

justin b. rye

If you don’t see the POST process and GRUB prompt, it’s conceivable you have kexec-tools installed (and enabled): kexec replaces reboots with a “warm reload” into whatever kernel is the target of /vmlinuz.  This is handy for minimising a server’s downtime during a kernel upgrade if its BIOS takes ages to initialise hardware, but less handy if you wanted to reboot into your Windows install!

NN comments
oz123
-

Hi Justin, at the moment this pacakge is not installed on my system, and the issue is solved. I don’t know why it was installed, but during one of the last upgrades it was removed (at least according to cat /var/log/dpkg.log | grep kexec 2011-05-12 06:28:33 remove kexec-tools 1:2.0.2-1

Thanks !

gnubyexample
-

“…cat /var/log/dpkg.log | grep kexec 2011-05-12 06:28:33 remove kexec-tools 1:2.0.2-1”

@oz123 seems the version of kexec-tools you had installed ( 1:2.0.2-1 ) was from unstable (sid)

The Q&A was helpful still as marking kexec-tools ‘manual’ and ‘forbid version’ in aptitude is something I will try to remember to do on desktops now.

The package hierarchy in unstable has dependencies which are mostly correct, however having unstable packages on your system, like you did, ( kexec-tools 1:2.0.2-1 ) does involve a little dependency risk – sometimes a package might be pulled down through a dependency that you weren’t expecting. http://packages.debian.org/source/unstable/kexec-tools

or Cancel
1

debuser

Hi

I had the same issue when i installed LMDE (Debian Testing). I found out that the problem was installed package “kexec-tools”. When i removed it the reboot process went perfectly on.
Search for this package if it is installed.

or Cancel
0

gnubyexample [ Editor ]

what happens if in a terminal you issue:

shutdown -r now

...does the machine go down as you expect?

Are you issuing the reboot from within a graphical environment (which?) or a bare tty console?

There is an Xfce group on identi.ca that might be worth joining, if the thing seems very Xfce specific, and you want to ask the programmers.

NN comments
oz123
-

like I said, when I issue reboot or shutdown -r now, the computer loads the newest kernel in the grub menu. Before I installed this Debian, reboot or shutdown -r now, behaved like I pressed the power button to put the computer off, and then pressed the button to put it on. Now the behavior is quite different. The computer goes to init 6, and then starts again.

Basically, before this reboot always behaved as “reboot -f” now… “reboot -f” now really brings up grub where I can choose my os. “reboot” just brings up the latest kernel.

or Cancel
0

khalid aziz

kexec-tools 2.0.2-1 and newer also include a command /sbin/coldreboot which performs the regular cold reboot going all the way into BIOS. If you have installed kexec-tools and use the kexec functionality, you can use coldreboot for the times when you want the machine to go all the way down to BIOS and GRUB. You can also edit /etc/default/kexec and set LOAD_KEXEC to “false” to disable kexec (warm) reboots without uninstalling kexec-tools. This setting is preserved across kexec-tools upgrades.

or Cancel
0

gnubyexample [ Editor ]

In a terminal issue:

grep TIMEOUT /etc/default/grub

…a value of 5 or 10 is a good suggested value for GRUB_TIMEOUT

At the end of this article there are two more variables you might query / set to adjust things to how you like them.

Any adjustments you make are best made via changes to /etc/grub.d/ so that they are included each time /boot/grub/grub.cfg is regenerated.

Run /usr/sbin/update-grub to regenerate /boot/grub/grub.cfg, and have the new options active at your next bootup

Warning – mistakes in editing these files might prevent your system from booting correctly, if you edit variable names / values wrong. Do have a rescue disk handy.

Following hints in articles at http://gnubyexample.blogspot.com/search/label/grub  you do so at your own risk.

In the grub manual you can read about GRUB_HIDDEN_TIMEOUT_QUIET

and any other variables that might be switched true / false.

[ I may have to re-edit this answer once or twice if the underscore to italic translator of ask.debian.net gets html wrong :| ]</grub_timeout=0>

or Cancel

Your answer

You need to join Debian to complete this action, click here to do so.