Feedback

type to search

GOsa in Squeeze: workstations aren't shown!. Could you help me to find out why?

Asked by , Edited by Tuxedoar

Hi,

I am trying to integrate GOsa web LDAP admin interface into an existing PDC with Samba and openldap, using Debian Squeeze. Everything is being done within a test environment composed by VMs.

First, I installed the gosa package (plus gosa-schema and gosa-plugin-samba packages) and added the following lines in /etc/ldap/slapd.conf:

include         /etc/ldap/schema/gosa/samba3.schema
include         /etc/ldap/schema/gosa/trust.schema
include         /etc/ldap/schema/gosa/gosystem.schema
include         /etc/ldap/schema/gosa/gofon.schema
include         /etc/ldap/schema/gosa/goto.schema
include         /etc/ldap/schema/gosa/gosa-samba3.schema
include         /etc/ldap/schema/gosa/gofax.schema
include         /etc/ldap/schema/gosa/goserver.schema
include         /etc/ldap/schema/gosa/goto-mime.schema

I left this other line commented:

include         /etc/ldap/schema/samba.schema

Later on, after setting up Apache, I went through the GOsa web based configuration wizzard. I made sure to setup the correct settings for users (ou=Users), groups (ou=Groups) and workstations (ou=Computers) according to my  LDAP tree. Everything went fine despite being warned that users wouldn’t be shown (I took care of that later!).

As I said, I managed users to show up in GOsa by adding the “gosaAccount” attribute in each LDAP user entry. However, I can’t figure out why the workstations inside the “ou=Computers” aren’t shown in GOsa.

Let me share some relevant entries in my LDAP tree:
 
# Computers, midominio.com.ar
dn: ou=Computers,dc=midominio,dc=com,dc=ar
ou: Computers
description: GOsa department
objectClass: top
objectClass: organizationalUnit
objectClass: gosaDepartment


# winseven$, Computers, midominio.com.ar
dn: uid=winseven$,ou=Computers,dc=midominio,dc=com,dc=ar
cn: winseven$
uid: winseven$
uidNumber: 1008
gidNumber: 515
homeDirectory: /dev/null
loginShell: /bin/false
description: Computer
gecos: Computer
sambaSID: S-1-5-21-4020910172-3506817343-313490316-1003
displayName: WINSEVEN$
sambaAcctFlags: [W          ]
objectClass: top
objectClass: account
objectClass: posixAccount
objectClass: sambaSamAccount

This lastest LDAP entry above, belongs to a workstation that is not shown by GOsa. I tried adding the “gosaAccount” attribute to it, but didn’t work.

Let me also show you some relevant settings in my /etc/gosa/gosa.conf:

http://pastebin.com/HFQwpShm

Besides, some google research often points out a “winstations” parameter inside gosa.conf, but I can’t find such thing in its man page. Is it because it’s not valid or used anymore?.

Also, I enabled the debug mode in GOsa, but didn’t help. Am I missing

something?. I don’t know what else to try or do so that GOsa show up the workstations!. 

GOsa version is 2.6.11.

Thanks in advance!.
Cheers!.  

or Cancel

Your answer

You need to join Debian to complete this action, click here to do so.