Feedback

type to search

By: Asked

Debian installation seemingly worked but booting results in blackscreen

Hello,

I bought a second SSD to install Debain as a second OS on my Desktop (Win10 as primary OS). After installing Debian from a USB stick, when i start my PC i get a screen where I can choose what to boot (Debain / Windows / some memory tests). Windows still works fine, but when i choose Debian i see a few lines of text / code for a split second then the screen goes all black and nothing more happens. 
The trial mode, where you can start Debian without installing it worked just fine, but when i tried installing Ubuntu before i had similar problems (when choosing the Ubuntu USB stick as boot medium i got a ubuntu loading screen then blackscreen without even getting to install it).
After a few tries i managed to take a picture of the text:
“Loading, please wait…
[ 0.563840][drm:radeonpciprobe] ERROR radeon ernel modesetting for R600 or later requires firmware-linux-nonfree”
So apparently it is a problem with my GPU (VTX3D AMD HD 7870 Black Edition)
According to https://packages.debian.org/jessie/kernel/firmware-linux-nonfree firmware-linux-nonfree is a package that includes firmware for various stuff including GPUs. How can i get this package if i can’t boot Debian?
You need to join Debian to complete this action, click here to do so.